安裝GD2.0.28

DATE: 09/30/2004 11:55:44 AM

07/21/04: gd 2.0.28 has been released. gd 2.0.28 restores support for reading and writing GIF images. There is also a fix for a possible problem in gdImageTrueColorToPalette.

這是新版GD RELEASE的消息,由於GIF的壓縮專利到期
大部分國家都可以自由使用GIF格式的壓縮技術了
於是新版的GD便將之納入
但是PHP要升級到4.3.9以後才行

作法大致上很簡單
GD的網站上下載2.0.28版本的GD
PHP的網站上下載新版的PHP
(其實我也不確定不更新PHP能不能用,不過,反正舊版有BUG就順便換了)
安裝新版的GD,需要有libpng,libjpeg,zlib
因為原本懶惰用的是FEDORA的BINARY檔
結果找不到JPEG與PNG的LIB
後來發現被放在/usr/lib下而且沒有libpng.so的LINK得要自己加
但是,即使如此一樣因為欠缺HEADER FILE所以無法COMPILER

所以有很多人喜歡純手工
因為找檔案是很囉唆麻煩的事情

即使是不使用4.3.9
好像也是很正常
看不出來有改變什麼

在裝PHP的過程中發現到INSTALL文件中提到

Do not use Apache 2.0.x and PHP in a production environment neither on Unix nor on Windows. For information on why, read the following FAQ entry
Rasmus Lerdorf <=此人為PHP的大頭頭,一人決定PHP的發展方向
的解釋有點籠統,簡單的說就是PHP是針對APACHE1所寫的
並不保證在2上沒有問題因為PHP是黏合許多第三方的函式庫,這些函式庫是否都合乎APACHE2的THREAD SAFE要求是個未知數
是以建議不要使用APACHE2與PHP在正式環境上

廣告

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com 標誌

您的留言將使用 WordPress.com 帳號。 登出 /  變更 )

Google+ photo

您的留言將使用 Google+ 帳號。 登出 /  變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 /  變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 /  變更 )

連結到 %s